RAVE Control V2 Universal Auslassteuerung mit Modellbauservo

  • Hier wie versprochen die Weiterentwicklung mit der ein Powervalvesystem am Moped mit Handelsüblichen Modellbauservos gesteuert werden kann.



    Im Status: getestet und für gut befunden :daumenhoch


    Funktioniert bis jetzt seit 1500 Km, davon 550 Km im Regen



    Aktuell geht nur auf und zu, mehrere Zwischenstufen sind ohne Probleme im Code implementierbar.


    Die Bauanleitung ist weitgehend Identisch mit der der RAVE_Control
    nur der Verdrahtungsplan hat sich geändert:


    RAVE Control. einstellbares Zusatzsteuergerät im Eigenbau



    Zur Teileliste gesellt sich noch eine 6 Volt 5 Ampere Servostromversorgung:
    https://www.ebay.de/itm/Modelc…0d2ff7:g:m7cAAOSw~Kpcxzer


    und ein Kräftiger Digitalservo vom Typ SPT5435LV 180W
    https://www.ebay.de/itm/35KG-S…ksid=p2060353.m2749.l2649



    Die Servohalterung ist eine Chinesiche Schleppkupplung für Modellflieger. (Gewinde für Bowdenzughalter muss rein geschnitten werden)
    https://www.ebay.de/itm/Lenkse…ksid=p2060353.m2749.l2649





    Die Drehzahlabnahme funktioniert auch an der Zündspule. Nach dem mich Manuel mit der niedrigen Pickupspannung geschockt hat, habe ich noch Alternativen probiert.
    Die CDI schickt eine Negative Spannung gegen Masse zur Zündspule, entsprechend muss der mit "GND" Beschriftete Pin des Optokopplers an den Zündimpulseingang der Zündspule geschalten werden und der mit "PWM" beschriftete Eingang über einen 4,5 KOhm Widerstand auf Masse geschalten werden (Siehe Verdrahtungsplan).


    Diese Art der Anschaltung funktioniert auch bei der ersten version und meinem Schaltblitz.



    Die Modellauservos sind nicht so wirklich für Kraftfahrzeuge geeignet daher ist es sinnvoll die Zündkabel abzuschirmen um Servozucken zu vermeiden oder zumindest weitgehend zu reduzieren:


    Funkentstörung der RS125 nach Drehzahlmesserproblemen


    Im Anhang ist auch der Code zum reinkopieren in Arduino

  • Wie viel Ohm hast du von der Zündspule gemessen zu den 5V Plus am Optokoppler?



    Die CDI bzw. der Komdensator und das IC in der CDI mögen gar nicht, wenn man da ran geht. Daher wäre eine Abnahme nur über PickUp sinnvoll!


    Das gibt sonst Salat und die CDI brennt durch!


    Daher nur über PickUp oder über die Spulenspannung, die das werksseitige RAVE steuert.


    Dennoch: toll gemacht!


    Vielleicht sollten wir mal telefonieren. Du scheinst Die Zeit für Arduino und Co zu haben, die ich nicht habe :daumenhoch

    ich kompensiere Appetit durch Leichtbau :aha:

  • Sehr geil.... ich vermisse die YPVS meiner RD‘s an der RS....



    Edith: LOL, Autokorrektur hat aus ‚ge*l‘ ein ‚redlich‘ gemacht...

    LG
    B.

    Edited once, last by Bartimaus ().


  • Es sind insgesamt 5,5 KOhm Masse gegen Zündsignal/Zündspuleneingang mit der die CDI mehr belastet wird, das währen bei angenommen 20V Zündspannung(Ich hab die tatsächliche Primärspannung der CDI noch nicht gemessen) nur 3,6 mA und 72mW Mehrbelastung am Zündausgang der CDI


    Zu den 5V vom Arduino ist die Zündspule durch den Optokoppler größer 300MegaOhm Isoliert.
    Parallel zum Pickup funktioniert seit 2.000 Km, Die Abnahne an der Zündspule muss noch ausgiebig getestet werden da der Original Drehzahlmesser sein Signal auch von der Spule nimmt sollte es keine größeren Schwierigkeiten geben.


    Wir können gerne Texten und Telefonieren

    Nur was knattert und stinkt, mir Freude bringt :biggrin:

  • Das sieht richtig geil aus, ich bin mal auf den weiteren Verlauf gespannt :) :respekt:


    MCF

  • Hab heute wieder fleißig getestet: :)
    Habe das Steuergerät auf dem Tank und den Servo auf der Gabelbrücke befestigt um während der Fahrt zu sehen ob die Drehzahlmessung klappt und ob der Servo anfängt zu zucken



    Als Servo habe ich einen Chinesichen SPT5435LV Digitalservo besorgt.
    Das Servo hab ich mal zerlegt und es hat mich Überzeugt:
    * Metallgetriebe ab Werk gefettet und spielarm
    * Gehäuse und Servowelle mit O-ringen abgedichtet, Servowelle mit Kugellager gestützt
    * Platine ab werk dick mit Klarlack überzogen, der Motor mit gummiartiger Dichtmasse gegen Wasser
    tröpfchen gesichert
    * Kostet nur 21€ inklusive Versand
    * Laut einem Youtube Test hat er eine Stellkraft von 25 Kg bei 6Volt und 4 Ampere


    https://www.ebay.de/itm/35KG-S…ksid=p2057872.m2749.l2649


    Es funktioniert die Drezahlabnahme paralell zum Pickup und an der Zündspule.
    Da die Leerlaufspannung des Zündimpulses von der CDI 140 Volt beträgt (ohne angeschlossene Spule), werde ich bei Gelegenheit den Schaltplan für die Derhzahlabnahme an der Zündspule noch etwas anpassen damit der Optokpppler bei abgezogener oder defekter Spule keinen Schaden nimmt.
    (ist aber nicht erforderlich da bei 140 Volt ein impulsstrom von nur 23mA fließt, was noch in der Schmerztoleranz des Optokopplers liegt)
    Der Servo bleibt brav in seinen beiden Stellungen, auch bei Vollgas hab ich kein Servozucken. :biggrin:


    Was leider nicht funktioniert ist die Drehzahlmessung an der Lichtmaschine, es funktioniert nur so lange, bis die Originale Rave Einheit den Solenoiden ansteuert, ab da ist die Wechselspannung nicht mehr ohne weiteres auswertbar. Keine Ahnung was da passiert, das müsste mit dem Oszilloskop untersucht werden.
    Bei jedem anderen Fahrzeug funktioniert die Drehzahlmessung an der Lima problemlos, nur bei der Aprilia nicht, und auch nur dann nicht, wenn der Solenoid angesteuert wird.(der fliegt ja raus und wird durch den Servo ersetzt wo es theoretisch dann doch funktioniert, aber vorher will ich rausfinden wieso es nicht funktioniert)

    Nur was knattert und stinkt, mir Freude bringt :biggrin:

  • Jetzt wird ernst :D


    Sie ist eingebaut



    für ein Gehäuse war ich diesmal zu Faul, die komplette Elektronik ist mit Klarlack gegen Kondenswasser gesichert und in einem durchsichtigen Schrumpfschlauch eingeschrumpft und im Heck am Platz der alten Rave Einheit. Drehzahlabnahme hab ich wieder Am Pickup, da der Stecker von der Rave_Control_V1 bereits vorhanden war.



    Das Servosignal geht vom Heck mit einem geschirmten Antennenkabel ( RG58 ) nach Vorne, die 6V für den Servo laufen über das weiße Kabel von der Alten Rave einheit zum alten Solenoiden.


    Probefahrt war erfolgreich :freak
    Gleich mal einen persönlichen Geschwindigkeitsrekord von 172 Tacho Km/h aufgestellt, der kommt aber nicht von der Steuerung sondern von sehr starkem Rückenwind.


    Jetzt wird sich zeigen in wie lange ein Modellbauservo mit den Vibrationen, den Temperaturen und der Luftfeuchtigkeit im Moped klar kommt.


    Ich ergänze nach ein paar posiviven Testkilometern den ersten Post, um den Link zum Servo und der Servohalterung.

    Nur was knattert und stinkt, mir Freude bringt :biggrin:

  • Vibrationen sind kein Problem im Rc Bereich müssen die wesentlich mehr ab können . Problem ist höchstens wenn es zu schwer geht oder du immer gegen denn Endpunkt fahren lässt. Wasserdicht sind sie normalerweise auch.