Der Drehzahlmesser Reparatur Thread

  • Wenn die Zeigernadel ausgerichtet ist, kann der richtige Code für den Drehzahlmesser geladen werden:


    Nur was knattert und stinkt, mir Freude bringt :biggrin:

  • Den Arduino mit viel Heißleim gegen Feuchtigkeit schützen und auf die Rückseite des Steppers kleben und dabei so ausrichten das er später bei eingeschaltener Tachobeleuchtung auf das Ziffernblatt keinen Schatten wirft.


    Die Tachoeinheit wie folgt mit der Originalplatine verbinden:


    Alle größeren Bauteile reichlich mit Heißleim gegen Abvibrieren sichern. Kabel festkleben, damit sie nicht an der Lötstelle abvibrieren.



    Auch die Widerstände auf der Platine mit Heißleim gegen abvibrieren sichern


    Zeit für einen Trockentest mit dem Arduino Signalgenerator:


    External Content youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.


    Platine ins Gehäuse schrauben:


    Ziffernblatt Einheit ins Gehäuse einkleben:


    Tachoglas und Rahmen wieder aufkleben:


    Rein ins Moped damit:


    und Fertig:


    External Content youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    Nur was knattert und stinkt, mir Freude bringt :biggrin:

  • Das ganze fahre ich bereits seit fast einem Jahr und über 4.000 Km , bisher bekannte Probleme sind:


    * das fahren des Chinesichen Steppers auf Null nach dem anschalten der Zündung klappt nicht immer 100%ig so ist die Anzeige manchmal fehl kalibriert und weicht 100-200 rpm vom tatsächllichen Wert ab (Angesichts der bis zu 1000 rpm abweichung am perfekt kalibrierten Original Drehzahlmesser immer noch zu vernachlässigen)


    *an der Originalzündung funktioniert alles problemlos, an zubehör CDI`s habe ich ab und zu oberhalb 11.500 rpm einen leichten Zucker in der Nadel

    Nur was knattert und stinkt, mir Freude bringt :biggrin:

  • Höchsten Respekt meinerseits und danke für's Teilen der Ideen und Erfahrungen :respekt: :herz:

    "Heute ist die gute alte Zeit von morgen", Karl Valentin

  • Noch ein kurzes Update: ich habe ja extra für den Reparatur Thread einen Kleinanzeigen Drehzahlmesser bearbeitet und fürs Foto eingebaut.

    Den bin ich heute Probe gefahren und die sporadischen Zucker oberhalb 11.500 waren weg. Also hab ich meinen 1 Jahr alten Prototypen noch mal genau nach dieser Anleitung umgebaut und auch der zappelt jetzt an der Zubehörzündung nicht mehr.


    Unterschiede vom Drehzahlmesser aus meiner Anleitung zum Prototypen sind:


    * Der Optokoppler und der Kondensator C2 waren beim Prototypen nicht am Arduino direkt dran sondern auf der Originalplatine verbaut.


    *Der Vorwiderstand 5 Watt, 1 Ohm im Schaltplan existierte beim Prototypen nicht, beim Drehzahlmesser nach Anleitung werden die 5,6 + 3,9 Ohm von der Original Platine genutzt. Kolbi hat mir ja schon einmal den Tipp gegeben Vorwiderstände in der Stromversorgung zu nutzen, ein Positiver Effekt konnte heute nachgewiesen werden.

    Nur was knattert und stinkt, mir Freude bringt :biggrin: